Вопрос по информатике:
В массиве хранится информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешёвого (дорогого) товара и его индекс
- 15.09.2018 11:29
- Информатика
- remove_red_eye 8943
- thumb_up 16
Ответы и объяснения 1
#include
int main(){ const int kol_tov = 20;
int sbol = 0; int sbol_index = 0; int smal = 0; int smal_index = 0;
int massiv[kol_tov] = { 12, 150, 1230, 332, 531, 1321, 32313, 123123, 123434, 4844, 84847, 48816, 181684, 181, 78616, 81141, 1894, 18974, 91234, 21239 };
smal = massiv[1];
for (int i = 0; i sbol) { sbol = massiv[i]; sbol_index = i + 1; } if (massiv[i] < smal) { smal = massiv[i]; smal_index = i + 1; } }
std::cout << "Samoe dorogoe: " << sbol << std::endl << "Samoe deshevoe: " << smal << std::endl << "Index dorogogo: " << sbol_index << std::endl << "Index deshevogo: " << smal_index << std::endl; system("PAUSE");}
- 16.09.2018 19:16
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.