Вопрос по информатике:
Составить программу в Pascal, которая вводит строку символов, удаляя все символы, не являющиеся латинскими буквами и затем выводит результаты.
- 06.09.2017 10:59
- Информатика
- remove_red_eye 6008
- thumb_up 49
Ответы и объяснения 1
//PascalABC.NET 3.2 сборка 1318
var
s: string;
i,k: integer;
begin
readln(s);
i:=1;
k:=length(s);
while ik do
begin
k:=length(s);
if (upcase(s[i]) 'Z') then
begin
delete(s, i, 1);
i:=i-1;
end;
i:=i+1;
end;
writeln(s);
end.
Пример ввода:
Gleb1Kosyrev Sample Текст, Pointer Symbol is ^
Пример вывода:
GlebKosyrevSamplePointerSymbolis
- 07.09.2017 07:35
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.