Вопрос по информатике:
При выводе числовой информации с поясняющим текстом часто возникает проблема согласования выводимого значения и окончания поясняющего текста. Например, в зависимости от числового значения, поясняющий текст к денежной величине может быть «рубль», «рублей» или «рубля». Очевидно, что окончание поясняющего слова определяется двумя последними цифрами числа, что отражено в таблице.
2 последние цифры числа
Поясняющий текст
*0, *5, *6, *7, *8, *9, 11, 12, 13, 14
рублей
*1
рубль
*2, *3, *4
рубля
На место звездочки можно подставить любую цифру.
Составьте программу, которая обеспечивает ввод числа и вывод числа с поясняющим текстом (например, вводится число 35, выводится 35 рублей).
паскаль
- 19.05.2015 21:43
- Информатика
- remove_red_eye 6535
- thumb_up 20
Ответы и объяснения 1
Var
n,b: integer;
begin
writeln ('vvel n');
read (n);
b:= n mod 10;
if b=1 then writeln (n,'рубль');
if (b>1) and (b<5) then writeln (n,'рубля')
else
writeln (n,'рублей');
end.
- 20.05.2015 06:23
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.