Вопрос по информатике:
Имя входного файла input.txt
Имя выходного файла output.txt
Максимальное время работы на одном тесте 2 секунды
Ограничение по памяти 64 МБ
Недавно Шурик увлекся полетами на воздушном шаре. Все бы хорошо, но однажды у него закончилось топливо, и приземление оказалось очень жестким. Отделавшись легким испугом и парой царапин, он решил создать микроконтроллер, который бы сигнализировал о необходимости начать спуск.
Оказалось, что для плавного спуска нужно каждые два метра сжигать одну единицу горючего. Для простоты наш изобретатель решил, что сжигать нужно будет на каждой четной высоте. А дальше начались трудности, так как Шурик не силен в математике.
Помогите Шурику написать алгоритм, вычисляющий, какое количество единиц топлива необходимо для спуска с высоты A до высоты B над уровнем моря.
Формат входных данных
Во входном файле заданы два целых числа A и B (-2×109 ≤ A, B ≤ 2×109, A ≥ B) — начальная и конечная высоты над уровнем моря в метрах соответственно.
Формат выходных данных
В выходной файл выведите, какое количество единиц топлива необходимо для плавного приземления воздушного шара Шурика.
Пример
input.txt output.txt
3 0
2
0 -5
3
- 11.05.2018 07:59
- Информатика
- remove_red_eye 15087
- thumb_up 23
Ответы и объяснения 1
//Pascal ABC.NET 3.2 сборка 1318
Var
f:text;
n1,n2,k,i:integer;
begin
assign(f,'Input.txt');
reset(f);
read(f,n1);
read(f,n2);
close(f);
for i:=n1 downto n2 do
if i mod 2=0 then inc(k);
assign(f,'Output.txt');
rewrite(f);
write(f,k);
close(f);
end.
Пример содержимого Input.txt:
8 0
Пример содержимого Output.txt:
5
- 12.05.2018 11:46
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.