Вопрос по информатике:
Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года.
Пример:
Введите номер месяца:
5
Этот месяц - май, время года - весна.
Пример:
Введите номер месяца:
15
Неверный номер месяца.
- 10.05.2015 13:12
- Информатика
- remove_red_eye 4221
- thumb_up 19
Ответы и объяснения 1
Var n:integer;
begin
repeat
read(n);
if n12 then writeln('Неверный номер месяца');
until n=>1 and n<=12 ;
case n of
1: writeln('Этот месяц - Январь, время года - зима.');
2: writeln('Этот месяц - Февраль, время года - зима.');
3: writeln('Этот месяц - Март, время года - весна.');
4: writeln('Этот месяц - Апрель, время года - весна.');
5: writeln('Этот месяц - Май, время года - весна.');
6: writeln('Этот месяц - Июнь, время года - лето.);
7: writeln('Этот месяц - Июль, время года - лето.');
8: writeln('Этот месяц - Август, время года - лето.');
9: writeln('Этот месяц - Сентябрь, время года - осень.');
10: writeln('Этот месяц - Октябрь, время года - осень.');
11: writeln('Этот месяц - Ноябрь, время года - осень.');
12: writeln('Этот месяц - Декабрь, время года - зима.');
end;
end.
- 11.05.2015 22:57
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.