Вопрос по информатике:
Программа на с++.Составить программу для проверки утверждения:"Результатом вычисления значения выражения x^2+x+41 при x=(0,40), являются простые числа."
- 16.07.2018 21:18
- Информатика
- remove_red_eye 8946
- thumb_up 24
Ответы и объяснения 1
#include
#define left 0
#define right 40
int prime(int x){
int d = 2;
while(d < x && x%d != 0) d++;
return d == x;
}
int main(){
int x;
for(x = left; x <= right; x++)
if( !prime(x*x + x + 41) ){
printf("False \n%d^2 + %d + 41 = %d \n", x, x, x*x + x + 41);
break;
}
if(x > right) printf("True \n");
return 0;
}
- 17.07.2018 12:45
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.