Вопрос по информатике:
Напишите программу, которая вычисляет сумму всех делителей заданного натурального числа n и находит все нечётные делители этой суммы.
Входные данные
В первой строке входного файла Input.txt содержится одно целое число N(1<=N<=6*10в8степени)
Выходные данные
В выходной файл Output.txt вывести все нечётные делители в порядке возростания.
- 21.08.2017 21:13
- Информатика
- remove_red_eye 13917
- thumb_up 28
Ответы и объяснения 1
//PascalABC.NET 3.2 сборка 1318
Var
f:text;
n,sum,i:integer;
begin
assign(f,'Input.txt');
reset(f);
read(f,n);
close(f);
for i:=1 to n do
if n mod i=0 then sum:=sum+i;
assign(f,'Output.txt');
rewrite(f);
for i:=1 to sum do
if (sum mod i=0) and (odd(i)) then write(f,inttostr(i)+' ');
close(f);
end.
Пример содержимого Input.txt:
4
Пример содержимого Output.txt:
1 7
- 22.08.2017 14:06
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.