Вопрос по информатике:
PascalAbc.net написать программу Ввода-Вывода.
1. Разработать программу, которая предлагает пользователю ввести с клавиатуры значения трех переменных х1, х2, х3 (оператор readln()).
2. Выводит введенные значения в строчку, отводя на каждое число 6 позиций. При этом необходимо вывести имена соответствующих переменных.
3. Присваивает переменным новые значения 42, 7 и 34 соответственно.
4. Выводит новые значения переменных в столбик, отводя для каждого значения 4 позиции. При этом необходимо вывести имена соответствующих переменных.
- 17.09.2017 09:38
- Информатика
- remove_red_eye 771
- thumb_up 14
Ответы и объяснения 1
Var
x1,x2,x3: real;
begin
writeln ('vvedi tri cisla');
readln(x1,x2,x3);
write ('x1=',x1:6,'x2=',x2:6,'x3=',x3:6);
x1:=42;
x2:=7;
x3:=34;
writeln;
writeln ('x1=',x1:4);
writeln ('x2=',x2:4);
writeln ('x3=',x3:4);
end.
- 18.09.2017 04:47
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.