Вопрос по информатике:
Напишите программу, которая выводит номера элементов массива, равных заданному значению X .
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. В третьей строке записано число X . Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одной строке номера элементов массива, равных X , разделив их пробелами. Предполагается, что нумерация начинается с единицы. Если таких элементов нет, нужно вывести число -1.
Примеры
входные данные
5
1 2 1 3 5
1
выходные данные
1 3
- 17.10.2017 18:08
- Информатика
- remove_red_eye 7976
- thumb_up 11
Ответы и объяснения 1
Var a:array[1..10000] of integer;
n,x,i,k:integer;
begin
read(n);
k:=0;
for i:=1 to n do read(a[i]);
read(x);
for i:=1 to n do
if a[i]=x then begin
k:=k+1;
write(i,' ');
end;
if k=0 then write(-1);
end.
- 18.10.2017 10:40
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.