Вопрос по информатике:
Дан массив из 100 элементов. Необходимо заполнить первые n из них первыми n натуральными числами в порядке убывания.
Формат входных данных
С клавиатуры вводится натуральное число n (n≤100n≤100).
Формат выходных данных
Требуется вывести содержимое первых n элементов массива после заполнения согласно условию задачи. Элементы должны разделяться пробелами.
- 17.03.2018 04:32
- Информатика
- remove_red_eye 2148
- thumb_up 39
Ответы и объяснения 2
Var ar:array[1..100]of integer;
i,n:integer;
begin
read(n);
for i:=n downto 1 do
ar[i]:=i;
for i:=n downto 1 do
write(ar[i],' ');
end.
- 18.03.2018 04:04
- thumb_up 40
CLSINPUT NDIM A(N)FOR i = 1 TO N A(i) = INT(RND * 100)NEXT iFOR i = 1 TO N FOR j = 1 TO N IF A(i) > A(j) THEN SWAP A(i), A(j) NEXT jNEXT iFOR i = 1 TO N PRINT A(i);NEXT i
- 19.03.2018 20:32
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.