Вопрос по информатике:
JAVA
Дано число n. С начала суток прошло n минут. Определите, сколько часов и минут будут показывать электронные часы в этот момент. Программа должна вывести два числа: количество часов (от 0 до 23) и количество минут (от 0 до 59). Учтите, что число n может быть больше, чем количество минут в сутках.
- 04.10.2017 15:24
- Информатика
- remove_red_eye 10487
- thumb_up 26
Ответы и объяснения 1
import java.util.Scanner;
/**
* Created by Geek on 20.09.2016.
*/
public class getTime {
public static void main(String[] agrs){
Scanner in = new Scanner(System.in); // Создаем объект ввода через консоль
System.out.print("Сколько минут прошло, после начала дня:");
int n = in.nextInt();
if(n <= 59) {
System.out.print(String.format("Прошло 0 часов и %d минут",n));
} else if(n > 1440) {
n = n - ((n/1440)*1440);
System.out.print(String.format("Прошло %d часиков и %d минут",n/60,n%60));
} else {
System.out.print(String.format("Прошло %d часиков и %d минут",n/60,n%60));
}
}
}
- 05.10.2017 22:20
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.