Вопрос по информатике:
Напишите программу, которая вводит трёхзначное число и десятичную цифру. Определить, входит ли эта цифра в десятичную запись введённого числа.
- 01.06.2017 17:45
- Информатика
- remove_red_eye 12462
- thumb_up 37
Ответы и объяснения 1
Var n,m:integer;
begin
write('Число = '); readln(n);
write('Цифра = '); readln(m);
if (n div 100 = m)or(n div 10 mod 10 = m)or(n mod 10 = m)
then writeln('Цифра есть')
else writeln('Цифры нет');
end.
Пример:
Число = 519
Цифра = 5
Цифра есть
- 02.06.2017 07:41
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.