Вопрос по информатике:
Помогите пожалуйста. Напишите программу, которая возводит введённое число в степень 10, используя только операции сложения и умножения. Что произойдёт, если ввести большое число 78?
- 23.05.2016 17:11
- Информатика
- remove_red_eye 13708
- thumb_up 46
Ответы и объяснения 1
Var
n,p2,p8,r:integer;
begin
Write('Введите целое число: ');
Read(n);
p2:=n*n; { n^2 }
p8:=p2*p2; { n^4 }
p8:=p8*p8; { n^8 }
r:=p2*p8; { n^10 }
Writeln(r)
end.
Контрольные решения
Введите целое число: 2
1024
Введите целое число: 5
9765625
Введите целое число: 78
605996032
(на самом деле должно быть 8335775831236199424)
- 24.05.2016 18:44
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.