Вопрос по информатике:
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. Напишите программу, которая находит и выводит
номер третьего положительного элемента массива (если из массива вычеркнуть все неположительные элементы, этот элемент стоял бы в получившемся массиве на третьем месте). Если в массиве меньше, чем три положительных элемента, вывести сообщение об этом.
- 11.01.2018 00:03
- Информатика
- remove_red_eye 18771
- thumb_up 6
Ответы и объяснения 1
Const n=30;
var a:array[1..n] of integer;
k,i:integer;
begin
for i:=1 to n do begin
a[i]:=random(21)-10;
write(a[i],' ');
end;
writeln;
k:=0; i:=0;
while (i
i:=i+1;
if a[i]>0 then k:=k+1;
end;
if k=3
then writeln('Номер третьего положительного элемента = ',i)
else writeln('В массиве нет 3 положительных элементов');
end.
Пример (для n=20):
-4 -10 3 -4 6 1 -9 4 -10 -8 7 7 0 -2 9 -4 -10 -3 1 -2
Номер третьего положительного элемента = 6
- 11.01.2018 18:38
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.