Вопрос по информатике:
Дана последовательность целых чисел. Прищнак окончания ввода- число 0(элементом последовательности не считается ). В последовательности как минимум одно число. Написать программу, определяющую, является ли последовательность чисел возрастающей. Если да програма должна вывести true, если нет- false.
- 24.05.2018 17:01
- Информатика
- remove_red_eye 3326
- thumb_up 38
Ответы и объяснения 1
Var a,b:integer; l:boolean;
begin
write('a = ');
readln(a);
l:=true;
while (a0) do
begin
b:=a;
write('a = ');
readln(a);
if (a0)and(a<=b) then l:=false;
end;
writeln(l);
end.
Пример 1:
a = 3
a = 6
a = 9
a = 4
a = 0
False
Пример 2:
a = 3
a = 6
a = 7
a = 0
True
- 25.05.2018 18:34
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.