Вопрос по информатике:
Написать программу
Пользователь вводит число, проверить извлекается ли из это числа корень
- 17.05.2016 04:02
- Информатика
- remove_red_eye 14314
- thumb_up 19
Ответы и объяснения 1
Var a,b:integer;
begin
write('a = ');
readln(a);
b:=round(sqrt(a));
if b*b=a
then writeln('Yes, ',b,' * ',b,' = ',a)
else writeln('No');
end.
Пример:
a = 169
Yes, 13 * 13 = 169
- 18.05.2016 16:40
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.