Вопрос по информатике:
Составьте программу, определяющую, лежит ли точка с
указанными координатами X, Y на окружности радиуса R с центром в
начале координат.
Program Frankenstein;
var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=r
then writeln('Точка лежит на
окружности!')
Else writeln('Точка не лежит на
окружности!');
End.
Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?
- 15.06.2017 19:18
- Информатика
- remove_red_eye 13484
- thumb_up 24
Ответы и объяснения 1
R^2
Var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=sqr(r) then
writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
- 16.06.2017 05:26
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.