Вопрос по информатике:
Напишите программу, которая выводит первое слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.
на си
- 09.10.2017 08:23
- Информатика
- remove_red_eye 1651
- thumb_up 15
Ответы и объяснения 1
#include
#include
#include
#include
//Размер строки
#define n 255
int main(){
setlocale(LC_ALL, "rus");
char s[n];
char w[n];
printf("\n >> Введите строку:\n << ");
fgets(s, n, stdin);
for (int i = 0; i <= strlen(s); i++)
if (s[i] != ' ')
w[i] = s[i];
else {
w[i] = '\0';
break;
}
printf("\n >> Результат:\n >> ");
fputs(w, stdout);
system("pause>>void");
return 0;
}
- 01.01.1970 00:00
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.