Вопрос по информатике:
Составить программу ,которая подсчитывает общее количество целых пятизначных чисел,составленных из различных цифр,которые обладают тем свойством,что число,образованное первыми двумя цифрами ,будучи умноженным на среднию цифру ,дает число,образованное последними двумя числами
- 19.03.2016 11:48
- Информатика
- remove_red_eye 2105
- thumb_up 30
Ответы и объяснения 1
Var
a, b, c, d, e, n: integer;
begin
n := 0;
for a := 1 to 9 do
for b := 0 to 9 do
for c := 1 to 9 do
for d := 0 to 9 do
for e := 0 to 9 do
if (10 * a + b) * c = (10 * d + e) then n := n + 1;
Writeln(n)
end.
Тестовое решение:
196
- 20.03.2016 22:14
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.