Вопрос по информатике:
Составить программу
Дано трехзначное число. Верно ли, что:
1. сумма его цифр-число четное
2. цифры в числе располодены по возрастанию
3. в запись числа входит цифра 5
4. оно оканчивается на цифру 7
- 02.10.2017 14:57
- Информатика
- remove_red_eye 4527
- thumb_up 14
Ответы и объяснения 1
Var a,z,s,i,m:integer;
begin
readln(a);
s:=0;
z:=a;
for i:=1 to 3 do begin
s:=s+(z mod 10);
z:=z div 10;
end;
if s mod 2 = 0 then writeln('1. Верно')else writeln('1. Неверно');
z:=a;
s:=z mod 10;
z:=z div 10;
m:=0;
for i:=1 to 2 do begin
if s < z mod 10 then begin
m:=1;
break;
end
else begin
s:=z div 10;
z:=z div 10;
end;
end;
if m = 0 then writeln('2. Верно')else writeln('2. Неверно');
z:=a;
m:=0;
for i:=1 to 3 do begin
if z mod 10 = 5 then begin
m:=1;
break;
end else begin
z:=z div 10;
end;
end;
if m = 1 then writeln('3. Верно')else writeln('3. Неверно');
if a mod 10=7 then writeln('4. Верно')else writeln('4. Неверно');
end.
- 03.10.2017 22:43
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.