Вопрос по информатике:
Решить в целых числах уравнение ( ax + b ) : ( cx + d ) = 0.
Входные данные
Вводятся 4 числа: a, b, c и d; c и d не равны нулю одновременно.
Выходные данные
Необходимо вывести все решения, если их число конечно, “NO” (без кавычек), если решений нет, и “INF” (без кавычек), если решений бесконечно много.
Примеры
входные данные
1
1
2
2
выходные данные
NO
входные данные
2
-4
7
1
выходные данные
2
- 25.08.2017 11:43
- Информатика
- remove_red_eye 1553
- thumb_up 19
Ответы и объяснения 1
( ax + b ) : ( cx + d ) = 0
Сводим уравнение к системе:
{ ax + b = 0
{ cx + d ≠ 0
{ ax = -b
{ cx ≠ -d
Можно учесть все случаи, используя больше 16 условий, но я предпочту более оптимальный вариант, так как знаю как зависит количество корней линейного уравнения от коэффициентов.
Программа на паскале:
var a, b, c, d: real;
begin
read(a, b, c, d);
if (c = 0) and (d = 0) then writeln('NO')
else if (a = 0) and (b = 0) then writeln('INF')
else if a = 0 then writeln('NO')
else if c = 0 then writeln(-b/a)
else if b/a = d/c then writeln('NO')
else writeln(-b/a)
end.
- 26.08.2017 08:21
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.