Вопрос по информатике:
Написать программу , которая вводит с клавиатуры число от 0 до 999999(использовать переменные типа longint) и выдает на экран дисплея сумму цифр этого числа. Напишите в делфи пожалуйста.
- 25.06.2018 13:01
- Информатика
- remove_red_eye 12516
- thumb_up 29
Ответы и объяснения 1
Var
n: longint;
i, sum: integer;
begin
Readln(n);
Sum := 0;
while n > 0 do
begin
Sum := sum + (n mod 10);
n := n div 10;
end;
Writeln(sum);
end.
- 26.06.2018 12:18
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.