Вопрос по информатике:
Написать программу вычисления количества ненулевых элементов одномерного массива. В C++
- 07.07.2018 13:51
- Информатика
- remove_red_eye 4548
- thumb_up 17
Ответы и объяснения 2
#include #include using namespace std; void MassNullEllement(int *Mass){ int KolEl = 0 ; for(int a=0;a<5;a++){ if(Mass[a]!=0){KolEl++;} } cout<<"amount element not equal zero = "<
- 08.07.2018 14:21
- thumb_up 13
#include
using namespace std;
int main(){
int ar[10];
int k=0;
for(int i=0;i<10;i++){
cin>>ar[i];
if(ar[i]!=0)
k++;
}
cout<
cin.get();
}
Пример ввода:
1
0
0
0
0
1
1
1
1
Пример вывода:
6
- 09.07.2018 00:03
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.