Вопрос по информатике:
Срочно!! Паскаль!! Напишите программу которая определяет является ли заданное натуральное числом квадратом некоторого натурального числа
- 16.05.2015 00:13
- Информатика
- remove_red_eye 11094
- thumb_up 47
Ответы и объяснения 1
Var
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln('YES')
else
writeln('NO');
end.
- 17.05.2015 15:19
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.