Вопрос по информатике:
Алгоритм вычисления функции Fn,где n-натуральное число,задан следующими соотношениями:
F1=1;F2=1;
Fn=Fn-2+Fn-1 при n<2
Чему равно F5?
- 16.12.2017 00:19
- Информатика
- remove_red_eye 19098
- thumb_up 12
Ответы и объяснения 1
Ошибка в условии!
Fn=Fn-2+Fn-1 при n>2!
Программа для вычисления Fn (вместо 5 можно поставить другое число):
var f1,f2,fn,i:integer;
begin
f1:=1;f2:=1;
for i:=3 to 5 do
begin
fn:=f1+f2; f1:=f2; f2:=fn;
end;
writeln('fn=',fn);
end.
F3=1+1=2; F4=1+2=3; F5=2+3=5
- 17.12.2017 15:54
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.