Вопрос по информатике:
Напишите программу,которая в последовательности натуральных чисел определяет количество трехзначных чисел кратных 4.Программа получает на вход натуральные числа,количество введённых неизвестно ,последовательность чисел заканчивается числом 0(0-признак окончания ввода ,не входит в последовательность).Количество чисел не превышает 1000.Введенные числа не превышают 30000.Программа должна вывести одно число :количество трехзначных чисел ,кратных 4.Входные данные:120;9;365;4;0.Выходные данные:1.
- 10.03.2016 13:38
- Информатика
- remove_red_eye 18314
- thumb_up 10
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
var k:=0;
var n:integer;
Writeln('Вводите натуральные числа; 0 - окончание ввода');
repeat
Read(n);
if (n>99) and (n<1000) and (n mod 4=0) then Inc(k)
until n=0;
Writeln(k)
end.
- 11.03.2016 11:25
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.