Вопрос по информатике:
Дано трехзначное число . в нем зачеркнули первую цифру и приписали ее в конце числа , а вторую и третью поменяли местами . составить программу для нахождения полученного числа
- 03.04.2017 01:28
- Информатика
- remove_red_eye 8042
- thumb_up 33
Ответы и объяснения 2
Var a,b,c,x:integer;
begin
readln(a);
b:=a div 100;
c:=a div 10 mod 10;
x:=a mod 10;
writeln(c,x,b);
end.
- 04.04.2017 15:51
- thumb_up 33
Во-первых, примем ограничение: число должно быть натуральным. т.е. целым и положительным без записи знака.
Во-вторых, возможны два принципиально разных алгоритма.
Первый алгоритм предполагает, что число помещается оператором ввода в целочисленную переменную и тогда мы получаем первую цифру, как результат целочисленного деления на 10, третью - как остаток от целочисленного деления на 100, а вторую - как остаток от деления на 10 результата целочисленного деления на 10.
Второй алгоритм предполагает работу с символьным изображением числа, т.е. после ввода получается символьная строка длиной три. Первый (левый) символ будет первой цифрой числа и так далее.
Ниже приводятся тексты программ на языке Pascal, реализующие эти алгоритмы.
**********************************
var
n:integer;
begin
Write('Введите целое трехзначное число без знака: '); Readln(n);
Writeln(n mod 10,(n div 10) mod 10,n div 100)
end.
Тестовое решение:
Введите целое трехзначное число без знака: 123
321
**********************************
var
n:string;
begin
Write('Введите целое трехзначное число без знака: '); Readln(n);
Writeln(n[3],n[2],n[1])
end.
Тестовое решение:
Введите целое трехзначное число без знака: 123
321
- 05.04.2017 00:16
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.