Вопрос по информатике:
Напишите программу на языке программирования (или составьте алгоритм).
Заполнить массив В, состоящий из сорока элементов, случайными целыми числами
из интервала [–30; 50] и найти максимальный элемент.
- 25.12.2017 23:08
- Информатика
- remove_red_eye 7747
- thumb_up 44
Ответы и объяснения 1
var i,max:integer;
b:array[1..40] of integer;
begin
randomize;
for i:=1 to 40 do
begin
b[i]:=random(random(80))-30;
write(b[i],' ');
end;
writeln;
max:=b[1];
for i:=1 to 40 do
begin
if b[i]>= max then
begin
max:=b[i];
end;
end;
writeln('Максимальный элемент массива: ',max);
end.
- 26.12.2017 05:15
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.