Вопрос по информатике:
Составьте программу вычисления среднего арифметического элементов массива А, состоящего из N элементов (N задается в блоке констант, элементы массива вводятся случайно и берутся из диапазона от -50 до 50).
паскаль
- 11.08.2015 08:02
- Информатика
- remove_red_eye 16649
- thumb_up 28
Ответы и объяснения 1
//Pascal ABC.NET v3.1 сборка 1219
Const
n=15;
Var
ar:array[1..n] of integer;
i:integer;
sr:real;
begin
randomize;
writeln('Аrray:');
for i:=1 to n do
begin
ar[i]:=random(-50,50);
write(ar[i]:4);
sr:=sr+ar[i];
end;
writeln;
sr:=sr/n;
writeln('Sr=',sr);
end.
Пример работы программы:
Аrray:
-17 -7 31 49 -49 7 -6 17 30 37 25 -30 23 -40 7
Sr=5.13333333333333
- 12.08.2015 07:55
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.