Вопрос по информатике:
1.по заданным координатам точек А и Б вычислите длину от резка АБ
2.Известны длины сторон треугольника a,b,c. Напишите программу вычисляющую площадь этого треугольника
ИНФОРМАТИКА СРОЧНОО
- 07.06.2018 10:08
- Информатика
- remove_red_eye 11406
- thumb_up 22
Ответы и объяснения 1
1 задача
var
X_1, Y_1, X_2, Y_2, AC, BC, AB:real;
begin
writeln('Введите значания X_1 (точки A)');
readln(X_1);
writeln('Введите значания Y_1 (точки A)');
readln(Y_1);
writeln('Введите значания X_2 (точки B)');
readln(X_2);
writeln('Введите значания Y_2 (точки B)');
readln(Y_2);
AC:=X_2-X_1;
BC:=Y_2-Y_1;
AB:=sqrt((AC*AC)+(BC*BC));
writeln('Длинна отрезка AB равна ', AB);
end.
2 задача
var
A, B, C, P, S:real;
begin
writeln('Введите сторону A');
readln(A);
writeln('Введите сторону B');
readln(B);
writeln('Введите сторону C');
readln(C);
P:=(A+B+C)/2;
S:=sqrt(P*(P-A)*(P-B)*(P-C));
if(A+B<=C) or (A+C<=B) or (B+C<=A) then
writeln('Треугольник с такими сторонами не существует')
else
writeln ('Площадь треугольника по теореме Герона равна ', S);
end.
- 08.06.2018 00:43
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.