Вопрос по информатике:
Написать программу которая 10 раз выводит на екран Имя и Фамилию. Это турбо паскаль - использование цыклов while, for и других.пожалуйста очень надо!!))
- 13.09.2016 10:14
- Информатика
- remove_red_eye 5243
- thumb_up 31
Ответы и объяснения 2
Ниже жирным шрифтом приведен код программы на Паскале. В фигурных скобках обычным шрифтом - комментарии. Можно их оставить - компилятор не сможет их прочитать и программа все равно будет работать.
program printname;
var first_name, family_name : string;
i : byte;
begin
write('Введи свое имя: ');
readln(first_name);{считываем имя в переменную first_name}
write('Введи свою фамилию: ');
readln(family_name); {считываем фамилию в переменную family_name}
for i := 1 to 10 do writeln(family_name, ' ', first_name);{В цикле for со счетчиком i изменяющимся от 1 до 10 печатаем строки с фамилией и именем через пробел}
end.
- 14.09.2016 12:30
- thumb_up 46
// Программа выводит по 10 раз имя и фамилию тремя разными циклами for while
// repeat until
Program LoopName;
Uses Crt;
var name,s_name:string;
i:integer;
begin
clrscr;
write('Введите имя: ');
readln(name);
write('Введите фамилию: ');
readln(s_name);
writeln('Цикл For');
for i:=1 to 10 do writeln(name,' ',s_name );
writeln;
writeln('Цикл while');
i:=1;
while (i<=10) do
begin
writeln(name,' ',s_name );
i:=i+1;
end;
writeln;
writeln('Цикл repeat until');
i:=0;
repeat
writeln(name,' ',s_name );
i:=i+1;
until(i=10);
readkey;
end.
- 15.09.2016 21:46
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.