Вопрос по информатике:
Ребят решите задачи
1) Дан текст .Написать программу вставляющию после каждой запятой по одному пробелу.
2)Дан текст ,слова в тексте разделены одним и несколькими пробелами.Написатт программу выводящию все слова в алфавитном порядке.
- 07.07.2018 08:29
- Информатика
- remove_red_eye 2819
- thumb_up 33
Ответы и объяснения 2
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var s:=ReadlnString('>');
s:=s.Replace(',',', '); Writeln(s);
Writeln(NewLine,'Список слов:');
s.ToWords.OrderBy(x->x).Println(NewLine);
end.
Тестовый пример
> Это мой,плохо форматированный,но зато мой текст!
Это мой, плохо форматированный, но зато мой текст!
Список слов:
зато
мой
мой,
но
плохо
текст!
форматированный,
Это
- 08.07.2018 12:40
- thumb_up 21
//Pascal ABC.NET v3.1 сборка 1172
//1
Var
s:string;
i:integer;
begin
readln(s);
while i
inc(i);
if s[i]=',' then insert(' ',s,i+1);
end;
writeln(s);
end.
Пример ввода:
Some,awesome,test,text,
Пример вывода:
Some, awesome, test, text,
//2
Var
s:string;
i,k,j:integer;
ars:array of string;
begin
readln(s);
setlength(ars,length(s));
k:=0;
for i:=1 to length(s) do
begin
if (s[i]=' ') and (s[i+1]' ') and (ilength(s)) then inc(k) else ars[k]:=ars[k]+s[i];
end;
for i:=0 to k-1 do
for j:=i+1 to k do
if LowerCase(ars[i])>LowerCase(ars[j]) then
begin
s:=ars[i];
ars[i]:=ars[j];
ars[j]:=s;
end;
for i:=0 to k do
writeln(ars[i]);
end.
Пример ввода:
Очень много яков и антилоп
Пример вывода:
антилоп
и
много
Очень
яков
- 09.07.2018 17:01
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.