Вопрос по информатике:
В массиве [1..30} замените все отрицательные числа на 5, а оставшиеся на 2.
Желательно сделать через цикл For и написать программу.
- 10.05.2017 22:58
- Информатика
- remove_red_eye 10218
- thumb_up 46
Ответы и объяснения 1
Const n=30;
var a:array[1..n] of integer;
i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i]:4);
end;
writeln;
writeln('Измененный массив:');
for i:=1 to n do
if a[i]<0 then a[i]:=5 else a[i]:=2;
for i:=1 to n do write(a[i]:4);
writeln;
end.
Пример (для n=10):
Исходный массив:
-2 6 -4 7 -4 4 -9 5 2 1
Измененный массив:
5 2 5 2 5 2 5 2 2 2
- 11.05.2017 03:45
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.