Вопрос по информатике:
Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы,используя операторы While,Repeat ,For.
- 01.02.2018 21:45
- Информатика
- remove_red_eye 12541
- thumb_up 14
Ответы и объяснения 1
//1
const
n = 10;
var
a, i, sum: integer;
begin
sum := 0;
i := 1;
repeat
Write('Введите число = ');
Readln(a);
sum := sum + a;
i := i + 1;
until i > n;
Writeln('Среднее арифметическое = ', sum / n);
end.
//2
const
n = 10;
var
a, sum, i: integer;
begin
sum := 0;
i := 1;
while i <= n do
begin
Write('Введите число = ');
Readln(a);
sum := sum + a;
i := i + 1;
end;
Writeln('Среднее арифметическое = ', sum / n);
end.
//3
const
n = 10;
var
a, i, sum: integer;
begin
sum := 0;
for i := 1 To n Do
begin
Write('Введите число = ');
Readln(a);
Sum := Sum + a;
end;
Writeln('Среднее арифметическое = ', sum / n);
end.
- 02.02.2018 05:27
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.