Вопрос по информатике:
Знатки информатики помогите.
Написать программу которая определяет содержит ли массив чисел число Х. Массив и Х - целые числа.
- 17.09.2018 18:09
- Информатика
- remove_red_eye 2709
- thumb_up 43
Ответы и объяснения 1
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
begin
var n := readinteger('Размер массива ');
//Для теста заполним массив сл. числами
var a := arrrandom(n); a.Println;
var x:=readinteger('Введите число Х');
if x in a then writeln('массив содержит число ', x)
else writeln('массив не содержит число ', x)
end.
Тест №1
Размер массива 10
96 14 36 84 55 1 74 99 72 20
Введите число Х 14
массив содержит число 14
Тест №2
Размер массива 10
59 9 8 98 75 34 52 63 62 17
Введите число Х 55
массив не содержит число 55
- 18.09.2018 05:27
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.