Вопрос по информатике:
Написать программу которая из двух введенных с клавиатуры чисел определяет большее и возводит его в квадрат,а меньшее делит на 8
- 01.12.2017 01:03
- Информатика
- remove_red_eye 13301
- thumb_up 28
Ответы и объяснения 2
Var
a, b: real;
begin
readln(a, b);
if a = b then writeln('Числа равны')
else
if a > b then begin
a := sqr(a);b := b / 8;
end
else begin
b := sqr(b);a := a / 8;
end;
writeln('a = ', a, ' b=', b)
end.
- 02.12.2017 10:23
- thumb_up 21
// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
var a,b:real;
Write('Введите a и b: '); Read(a,b);
if a>b then (a,b):=(b,a);
Println(a/8,b*b)
end.
Тестовое решение:
Введите a и b: 34 12.7
1.5875 1156
- 03.12.2017 01:11
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.