Вопрос по информатике:
Написать программу, запрашивающая 3 целых числа и выводящая на экран сумму этих чисел, если максимум этих чисел больше 12.
- 17.06.2018 05:25
- Информатика
- remove_red_eye 4857
- thumb_up 40
Ответы и объяснения 1
//Нам не обязательно находить максимум чтобы выполнить условие
//Pascal ABC.NET v3.1 сборка 1172
//Продвинутый уровень
begin
var seq:=ReadArrInteger(3);
if seq.any(x -> x>12)=true then writeln(seq.Sum) else writeln('Нет')
end.
//"Школьный" уровень
Var
a,b,c:integer;
begin
read(a,b,c);
if (a>12) or (b>12) or (c>12) then writeln(a+b+c) else writeln('Нет');
end.
Пример ввода:
1
1
13
Пример вывода:
15
- 18.06.2018 21:45
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.