Вопрос по информатике:
Написать программу которая создает одномерный массив из n случайных эллементов (др1000) и выводит на экран
1. Сам массив
2. Кол-во нечет чисел
3. Наим. Эллемент Массива
4 ср. Ариф. Членов массива
- 24.04.2018 09:02
- Информатика
- remove_red_eye 8387
- thumb_up 19
Ответы и объяснения 1
Писал в среде PascalABC:
var a:array of integer;
k,min,s,n,i:integer;
begin
write('Задайте размер массива = ');readln(n);
writeln;
setlength(a,n);
for i:=0 to n -1 do begin
a[i]:=random(101);
if a[i] mod 2 0 then k:=k+1;
if (a[i] < min) or (i=0) then min:=a[i];
s:=s+a[i];
end;
writeln('Массив:');
writeln(a);
writeln('Кол-во нечетных элементов = ',k);
writeln('Минимум = ',min);
writeln('Среднее ариф. = ',s/n);
end.
- 25.04.2018 14:39
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.