Вопрос по информатике:
Напишите программу, которая в последовательность целых чисел определяет произведение первого числа и всех положительный чисел
- 26.05.2018 09:08
- Информатика
- remove_red_eye 5121
- thumb_up 26
Ответы и объяснения 2
Program pr;
uses crt;
Var a,k,k1:integer;
Begin
Writeln('Введите a');
readln(a);
k1:=1;
k:=0;
While (a0) and (k1<1000) do
Begin
if (a<0) and (a mod 2=0) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln('k=',k);
readln;
end.
- 27.05.2018 06:05
- thumb_up 19
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
var a:=SeqRandom(ReadInteger('n='),-20,20)
.Select(i->real(i)).ToArray;
a.Println;
var b:=a[0]*a.Skip(1).Where(x->x>0).Aggregate(1.0,(p,x)->p*x);
Writeln(b);
end.
Тестовое решение:
n= 15
14 17 5 -1 9 -18 2 3 -20 5 -10 0 4 -1 -8
1285200
Пояснения по каждому оператору
1. Запрашивается количество элементов в последовательности n, генерируется последовательность из n целых чисел в диапазоне от -20 до 20, затем элементы последовательности преобразуются в вещественное представление и образуют динамический массив а.
2. Элементы массива а выводятся на экран.
3. Первый элемент массива умножается на произведение остальных положительных элементов и результат присваивается переменной b.
4. Значение переменной b выводится на экран.
В целях небольшого упрощения предполагается, что n>1 и что среди элементов массива, за исключением первого, имеется хотя бы один положительный элемент. Это связано с тем, что в задании отсутствует описание действий в случае, если вышеописанное предположение окажется неверным.
Переход к вещественному представлению чисел связан с обходом переполнения разрядной сетки при целочисленном умножении для больших значений n.
- 29.05.2018 00:35
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.