Вопрос по информатике:
Напишите программу,которая в последовательности натуральных чисел определяет наибольшее число,кратное 3 и оканчивающееся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число,кратное 3 и оканчивающееся на 6. Количество чисел не превышает 1000. Введенные числа не превышают 30000.
Программа должна вывести одно число:наибольшее число,кратное 3 и оканчивающееся на 6.
- 27.04.2018 12:47
- Информатика
- remove_red_eye 17406
- thumb_up 23
Ответы и объяснения 1
Var a,n,i,max36:integer;
begin
readln(n);
max36:=6;
for i:=1 to n do begin
readln(a);
if (a mod 3 =0) and (a mod 10=6) and (a>max36) then
max36:=a;
end;
writeln(max36);
end.
Тестовое решение:
5
6
36
48
66
124
66
- 28.04.2018 18:33
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.