Вопрос по информатике:
Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:
F(0) = 1, F(1) = 1
F(n) = F(n–1)*F(n-2)+2, при n > 1
Чему равно значение функции F(5)? В ответе запишите только целое число.
- 06.02.2016 09:42
- Информатика
- remove_red_eye 6163
- thumb_up 44
Ответы и объяснения 1
1. Ручная прокрутка алгоритма
F₀ = 1; F₁ = 1;
F₂ = F₁×F₀+2 = 1×1+2=1+2 = 3;
F₃ = F₂×F₁+2 = 3×1+2 = 3+2 = 5;
F₄ = F₃×F₂+2 = 5×3+2 = 15+2 = 17;
F₅ = F₄×F₃+2 = 17×5+2 = 85+2 = 87
Ответ: 87
2. Программное решение с использованием итерации
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
var f:array[0..5] of integer;
f[0]:=1; f[1]:=1;
for var i:=2 to 5 do f[i]:=f[i-1]*f[i-2]+2;
Writeln(f[5])
end.
Результат выполнения программы
87
3. Программное решение с использованием рекурсии
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
function f(n:integer):integer;
begin
if n<2 then Result:=1
else Result:=f(n-1)*f(n-2)+2
end;
begin
Writeln(f(5))
end.
Результат выполнения программы
87
- 07.02.2016 05:37
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.