Вопрос по информатике:
Напишите программу в PASCAL, которая проверяет делимость введенного числа с клавиатуры на 2,3,4,5 СРОЧНО!!!!
- 19.09.2018 13:23
- Информатика
- remove_red_eye 5078
- thumb_up 10
Ответы и объяснения 1
Var a:integer;
flag:boolean;
begin
flag:=false;
write('Введите число ');
readln(a);
if a mod 2 = 0 then begin
writeln('Число ',a,' делится на 2');
flag:=true;
end;
if a mod 3 = 0 then begin
writeln('Число ',a,' делится на 3');
flag:=true;
end;
if a mod 4 = 0 then begin
writeln('Число ',a,' делится на 4');
flag:=true;
end;
if a mod 5 = 0 then begin
writeln('Число ',a,' делится на 5');
flag:=true;
end;
if not flag then writeln('Число ',a,' не делится на 2,3,4,5');
end.
- 20.09.2018 13:26
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.