Вопрос по информатике:
Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального N . Алгоритм должен быть типа while
- 10.05.2016 16:38
- Информатика
- remove_red_eye 11842
- thumb_up 22
Ответы и объяснения 1
Вроде так, протести, у меня нет возможности.
Var N, i: integer;
begin
readln(N);
i:=1;
while i<=N do
begin
i:=i+(i+1);
end;
writeln(i);
end.
- 11.05.2016 03:08
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.