Вопрос по информатике:
Pascal 1. Дан прямоугольный треугольник с катетами a и b. Составьте программу для вычисления гипотенузы c, периметра, площади, радиуса вписанной и описанной окружности.
напишите программу в pascal
- 13.09.2017 14:42
- Информатика
- remove_red_eye 5154
- thumb_up 45
Ответы и объяснения 1
Program calculations;
var a,b,c, S, P,poluperimetr , Radius1, radius2: real;
begin
writeln ('Enter a:');
readln(a);
writeln('Enter b:');
readln(b);
c:=sqrt(a*a+b*b);
S:=(a*b)/2;
P:=a+b+c;;
poluperimetr:=P/2;
Radius1:=c/2;
radius2:=sqrt(((poluperimetr-a)*(poluperimetr-b)*(poluperimetr-c))/poluperimetr);
writeln('c=',c:2:2);
writeln('S=',S:2:2);
writeln('P=',P:2:2);
writeln('Radius1=',Radius1:2:2);
writeln('radius2=',radius2:2:2);
readln;
end.
- 14.09.2017 23:48
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.