Вопрос по информатике:
Заданы две клетки шахматной доски. Если они покрашены в один цвет, то выведите слово YES, а если в разные цвета — то NO. Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки.
- 11.06.2018 02:04
- Информатика
- remove_red_eye 13545
- thumb_up 25
Ответы и объяснения 1
Клетка будет черной, если номер столбца и номер строки будут одновременно четными или нечетными. Белыми, если один из них четный, а второй нечетный.
var a,b,c,d,t,k:integer;
begin
k:=0;
t:=0;
read(a);
read(b);
read(c);
read(d);
if (a mod 2=0) and (b mod 2=0) or (a mod 2=1) and (b mod 2=1) then
t:=1;
if (c mod 2=0) and (d mod 2=0) or (c mod 2=1) and (d mod 2=1) then
k:=1;
if tk then
writeln('NO')
else
writeln('YES');
end.
- 12.06.2018 00:24
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.