Вопрос по информатике:
Составить программу заполнения массива а[1..10] следующими числами:индекс массива 1 2 3 4 5 6 7 8 9 10
значение элемента 1 6 3 12 5 18 7 24 9 30
закономерность- значения элементов с нечетными индексами равны индексу элемента,а значения элементов с четными индексами-утроенному индексу элемента
нужно он var то end.
- 02.07.2018 00:49
- Информатика
- remove_red_eye 778
- thumb_up 12
Ответы и объяснения 2
Const
n = 10;
var
a: array[1..n] of integer;
i: integer;
begin
Write('Элементы массива: ');
for i := 1 to n do
begin
if (i mod 2) = 0 then a[i] := 3 * i else a[i] := i;
Write(a[i]:3)
end
end.
Тестовое решение:
Элементы массива: 1 6 3 12 5 18 7 24 9 30
- 03.07.2018 20:21
- thumb_up 24
Var
i,n:integer;
f1,f2:text;
begin
assign(f1, 'input.txt');
assign(f2, 'output.txt');
reset(f1);
rewrite(f2);
read (f1,n);
for i:=1 to n do
if (i mod 2) = 1 then write(f2, i, ' ' ) else write (f2, i*3, ' ');
close(f1);
close(f2);
end.
- 04.07.2018 03:54
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.