Вопрос по информатике:
Написать программу в на языке Pascal. По желанию помочь понять, что в моем коде не так: var a, b, c, s, k, y:real;
begin
writeln('Введите числа a,b,c');
readln(a, b, c);
s :=(sqrt(a + b*b*b*b*b))/(3 * c);
k :=s - (sqrt(abs(a * b * c)));
y :=(s + k) - (s/(b*c));
writeln('y= ',y);
end.
(человека, который поможет отмечу лучшим)
- 27.01.2018 02:37
- Информатика
- remove_red_eye 9792
- thumb_up 38
Ответы и объяснения 1
При таком наборе данных при вычислении значения s получается корень квадратный из отрицательного числа -29. Поэтому программа и выдает сообщение : Не число.
Набор данных некорректен.
- 28.01.2018 19:18
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.