Вопрос по информатике:
Для разных чисел вводимых с клавиатуры найдите сумму положительных не чётных.Написать программу на Паскале.
- 27.12.2017 06:36
- Информатика
- remove_red_eye 18698
- thumb_up 39
Ответы и объяснения 1
Program summ;
var
n, sum : integer;
begin
writeln('Вводите числа (введите 0 для выхода):');
sum := 0;
repeat
readln(n);
if ((n>0) and (n mod 2 0)) then
sum := sum+n;
until n=0;
writeln ('Сумма положительных нечётных чисел равна ', sum);
end.
- 28.12.2017 22:07
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.