Вопрос по информатике:
Составить программу нахождения суммы чисел от 100 до 200 кратных 7
- 26.01.2018 12:45
- Информатика
- remove_red_eye 7215
- thumb_up 18
Ответы и объяснения 1
Найдем первое число из данного диапазона, кратное семи.
100 / 7 = 14 и остаток 2.
100 + (7-2) = 105. (можно найти это число и другими путями).
И теперь задача сводится к нахождению суммы чисел последовательности 105, 112, ... где последнее число не превышает 200,
// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
Writeln('S=',Range(105,200,7).Sum)
end.
Тестовое решение:
S=2107
- 27.01.2018 02:41
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.