Вопрос по информатике:
Помогите написать программу на паскале абс
тема"Работа с элементами одномерных массивов"
Создать два одномерных массива, состоящих из целых чисел. Элементы массива
вводятся с клавиатуры. В первом массиве найти номер первого элемента массива больше
5. Во втором массиве найти первый нечетный элемент массива.
- 03.09.2017 09:35
- Информатика
- remove_red_eye 11861
- thumb_up 45
Ответы и объяснения 1
//Pascal ABC.NET v3.1 сборка 1172
Const
n=5;
Var
ar1,ar2:array[1..n] of integer;
i,k,m:integer;
begin
writeln('Reading array A:');
for i:=1 to n do
readln(ar1[i]);
writeln('Reading array B:');
for i:=1 to n do
readln(ar2[i]);
writeln('Res:');
for i:=1 to n do
if ar1[i]>5 then
begin
writeln(i);
break;
end;
for i:=1 to n do
if odd(ar2[i]) then
begin
writeln(ar2[i]);
break;
end;
end.
Пример ввода:
Array A:
1
2
4
5
9
Array B:
1
4
7
9
13
Пример вывода:
Res:
5
1
- 04.09.2017 16:27
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.